1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
foohey@sd-29922:~/www/rails-gcp$ gem install bundler
Successfully installed bundler-1.0.21
1 gem installed
Installing ri documentation for bundler-1.0.21...
Installing RDoc documentation for bundler-1.0.21...
foohey@sd-29922:~/www/rails-gcp$ bundle
Fetching source index for http://rubygems.org/
Using rake (0.9.2)
Installing multi_json (1.0.3)
Installing activesupport (3.1.0)
Installing bcrypt-ruby (3.0.1) with native extensions
Installing builder (3.0.0)
Installing i18n (0.6.0)
Installing activemodel (3.1.0)
Installing erubis (2.7.0)
Installing rack (1.3.5)
Installing rack-cache (1.0.3)
Installing rack-mount (0.8.3)
Installing rack-test (0.6.1)
Installing hike (1.2.1)
Installing tilt (1.3.3)
Installing sprockets (2.0.3)
Installing actionpack (3.1.0)
Installing mime-types (1.16)
Installing polyglot (0.3.2)
Installing treetop (1.4.10)
Installing mail (2.3.0)
Installing actionmailer (3.1.0)
Installing active_utils (1.0.1)
Installing braintree (2.12.0)
Installing json (1.6.1) with native extensions
Installing money (3.7.1)
Installing activemerchant (1.18.1)
Installing arel (2.2.1)
Installing tzinfo (0.3.30)
Installing activerecord (3.1.0)
Installing activeresource (3.1.0)
Installing ansi (1.3.0)
Installing bb-ruby (0.9.5)
Using bundler (1.0.21)
Installing bzip2-ruby (0.2.7) with native extensions
Installing cancan (1.6.7)
Installing cgi_multipart_eof_fix (2.5.0)
Installing chunky_png (1.2.5)
Installing coffee-script-source (1.1.2)
Installing execjs (1.2.9)
Installing coffee-script (2.2.0)
Installing rack-ssl (1.3.2)
Installing rdoc (3.11)
Installing thor (0.14.6)
Installing railties (3.1.0)
Installing coffee-rails (3.1.1)
Installing fssm (0.2.7)
Installing sass (3.1.10)
Installing compass (0.12.alpha.0)
Installing country-select (1.0.5)
Installing daemons (1.1.4)
Installing delayed_job (2.1.4)
Installing orm_adapter (0.0.5)
Installing warden (1.0.6)
Installing devise (1.4.9)
Installing eventmachine (0.12.10) with native extensions
Using fastthread (1.0.7)
Installing rails (3.1.0)
Installing formtastic (2.0.2)
Installing forum_monster (1.0.2)
Installing gem_plugin (0.2.3)
Installing gravtastic (3.2.6)
Installing jquery-rails (1.0.16)
Installing libv8 (3.3.10.2)
Installing mongrel (1.1.5) with native extensions
Installing mysql2 (0.3.7) with native extensions
Installing net-ssh (2.2.1)
Installing net-sftp (2.0.5)
Installing sass-rails (3.1.4)
Installing ssl_requirement (0.1.0)
Installing therubyracer (0.9.8) with native extensions
Gem::Installer::ExtensionBuildError: ERROR: Failed to build gem native extension.

/usr/bin/ruby1.8 extconf.rb
*** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of
necessary libraries and/or headers.  Check the mkmf.log file for more
details.  You may need configuration options.

Provided configuration options:
        --with-opt-dir
        --without-opt-dir
        --with-opt-include
        --without-opt-include=${opt-dir}/include
        --with-opt-lib
        --without-opt-lib=${opt-dir}/lib
        --with-make-prog
        --without-make-prog
        --srcdir=.
        --curdir
        --ruby=/usr/bin/ruby1.8
/usr/lib/ruby/1.8/rubygems/gem_path_searcher.rb:95:in `lib_dirs_for': undefined method `join' for "lib":String (NoMethodError)
        from /usr/lib/ruby/1.8/rubygems/gem_path_searcher.rb:20:in `initialize'
        from /usr/lib/ruby/1.8/rubygems/gem_path_searcher.rb:19:in `each'
        from /usr/lib/ruby/1.8/rubygems/gem_path_searcher.rb:19:in `initialize'
        from /usr/lib/ruby/1.8/rubygems.rb:841:in `new'
        from /usr/lib/ruby/1.8/rubygems.rb:841:in `searcher'
        from /usr/lib/ruby/1.8/rubygems.rb:840:in `synchronize'
        from /usr/lib/ruby/1.8/rubygems.rb:840:in `searcher'
        from /usr/lib/ruby/1.8/rubygems.rb:479:in `find_files'
        from /usr/lib/ruby/1.8/rubygems.rb:983:in `load_plugins'
        from /usr/lib/ruby/1.8/rubygems.rb:1139
        from extconf.rb:6:in `require'
        from extconf.rb:6


Gem files will remain installed in /home/foohey/.gem/gems/therubyracer-0.9.8 for inspection.
Results logged to /home/foohey/.gem/gems/therubyracer-0.9.8/ext/v8/gem_make.out
An error occured while installing therubyracer (0.9.8), and Bundler cannot continue.
Make sure that `gem install therubyracer -v '0.9.8'` succeeds before bundling.
foohey@sd-29922:~/www/rails-gcp$ gem install therubyracer -v '0.9.8'
/usr/lib/ruby/1.8/rubygems/gem_path_searcher.rb:95:in `lib_dirs_for': undefined method `join' for "lib":String (NoMethodError)
        from /usr/lib/ruby/1.8/rubygems/gem_path_searcher.rb:20:in `initialize'
        from /usr/lib/ruby/1.8/rubygems/gem_path_searcher.rb:19:in `each'
        from /usr/lib/ruby/1.8/rubygems/gem_path_searcher.rb:19:in `initialize'
        from /usr/lib/ruby/1.8/rubygems.rb:841:in `new'
        from /usr/lib/ruby/1.8/rubygems.rb:841:in `searcher'
        from /usr/lib/ruby/1.8/rubygems.rb:840:in `synchronize'
        from /usr/lib/ruby/1.8/rubygems.rb:840:in `searcher'
        from /usr/lib/ruby/1.8/rubygems.rb:479:in `find_files'
        from /usr/lib/ruby/1.8/rubygems.rb:983:in `load_plugins'
        from /usr/lib/ruby/1.8/rubygems.rb:1139
        from /usr/bin/gem:8:in `require'
        from /usr/bin/gem:8
foohey@sd-29922:~/www/rails-gcp$ gem update --system
/usr/lib/ruby/1.8/rubygems/gem_path_searcher.rb:95:in `lib_dirs_for': undefined method `join' for "lib":String (NoMethodError)
        from /usr/lib/ruby/1.8/rubygems/gem_path_searcher.rb:20:in `initialize'
        from /usr/lib/ruby/1.8/rubygems/gem_path_searcher.rb:19:in `each'
        from /usr/lib/ruby/1.8/rubygems/gem_path_searcher.rb:19:in `initialize'
        from /usr/lib/ruby/1.8/rubygems.rb:841:in `new'
        from /usr/lib/ruby/1.8/rubygems.rb:841:in `searcher'
        from /usr/lib/ruby/1.8/rubygems.rb:840:in `synchronize'
        from /usr/lib/ruby/1.8/rubygems.rb:840:in `searcher'
        from /usr/lib/ruby/1.8/rubygems.rb:479:in `find_files'
        from /usr/lib/ruby/1.8/rubygems.rb:983:in `load_plugins'
        from /usr/lib/ruby/1.8/rubygems.rb:1139
        from /usr/bin/gem:8:in `require'
        from /usr/bin/gem:8
foohey@sd-29922:~/www/rails-gcp$ gem
/usr/lib/ruby/1.8/rubygems/gem_path_searcher.rb:95:in `lib_dirs_for': undefined method `join' for "lib":String (NoMethodError)
        from /usr/lib/ruby/1.8/rubygems/gem_path_searcher.rb:20:in `initialize'
        from /usr/lib/ruby/1.8/rubygems/gem_path_searcher.rb:19:in `each'
        from /usr/lib/ruby/1.8/rubygems/gem_path_searcher.rb:19:in `initialize'
        from /usr/lib/ruby/1.8/rubygems.rb:841:in `new'
        from /usr/lib/ruby/1.8/rubygems.rb:841:in `searcher'
        from /usr/lib/ruby/1.8/rubygems.rb:840:in `synchronize'
        from /usr/lib/ruby/1.8/rubygems.rb:840:in `searcher'
        from /usr/lib/ruby/1.8/rubygems.rb:479:in `find_files'
        from /usr/lib/ruby/1.8/rubygems.rb:983:in `load_plugins'
        from /usr/lib/ruby/1.8/rubygems.rb:1139
        from /usr/bin/gem:8:in `require'
        from /usr/bin/gem:8