1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
>> quintus@kerberos => /opt/rubies/ruby-1.9.2-p0/lib/ruby/gems/1.9.1/gems/wxruby-ruby19-2.0.1-x86_64-linux/samples/minimal
$ ruby -dw minimal.rb
Exception `LoadError' at <internal:lib/rubygems/custom_require>:29 - no such file to load -- rubygems/defaults/operating_system
Exception `LoadError' at <internal:lib/rubygems/custom_require>:37 - no such file to load -- rubygems/defaults/operating_system
Exception `LoadError' at <internal:lib/rubygems/custom_require>:29 - no such file to load -- rubygems/defaults/ruby
Exception `LoadError' at <internal:lib/rubygems/custom_require>:37 - no such file to load -- rubygems/defaults/ruby
Exception `NameError' at /opt/rubies/ruby-1.9.2-p0/lib/ruby/1.9.1/syck/tag.rb:81 - method `yaml_as' not defined in Module
<internal:lib/rubygems/custom_require>:29: warning: loading in progress, circular require considered harmful - /opt/rubies/ruby-1.9.2-p0/lib/ruby/1.9.1/rubygems.rb
  from minimal.rb:5:in `<main>'
  from <internal:lib/rubygems/custom_require>:29:in `require'
  from <internal:lib/rubygems/custom_require>:29:in `require'
  from /opt/rubies/ruby-1.9.2-p0/lib/ruby/1.9.1/rubygems.rb:1136:in `<top (required)>'
  from /opt/rubies/ruby-1.9.2-p0/lib/ruby/1.9.1/rubygems.rb:968:in `load_plugins'
  from /opt/rubies/ruby-1.9.2-p0/lib/ruby/1.9.1/rubygems.rb:968:in `each'
  from /opt/rubies/ruby-1.9.2-p0/lib/ruby/1.9.1/rubygems.rb:976:in `block in load_plugins'
  from /opt/rubies/ruby-1.9.2-p0/lib/ruby/1.9.1/rubygems.rb:976:in `load'
  from /opt/rubies/ruby-1.9.2-p0/lib/ruby/gems/1.9.1/gems/hanna-0.1.12/lib/rubygems_plugin.rb:2:in `<top (required)>'
  from <internal:lib/rubygems/custom_require>:29:in `require'
  from <internal:lib/rubygems/custom_require>:29:in `require'
  from /opt/rubies/ruby-1.9.2-p0/lib/ruby/1.9.1/rubygems/doc_manager.rb:8:in `<top (required)>'
  from <internal:lib/rubygems/custom_require>:29:in `require'
  from <internal:lib/rubygems/custom_require>:29:in `require'
Exception `LoadError' at <internal:lib/rubygems/custom_require>:29 - no such file to load -- wx
/opt/rubies/ruby-1.9.2-p0/lib/ruby/gems/1.9.1/gems/wxruby-ruby19-2.0.1-x86_64-linux/lib/wxruby2.so: warning: method redefined; discarding old get_alpha_data
/opt/rubies/ruby-1.9.2-p0/lib/ruby/gems/1.9.1/gems/wxruby-ruby19-2.0.1-x86_64-linux/lib/wxruby2.so: warning: method redefined; discarding old get_rgb_data
/opt/rubies/ruby-1.9.2-p0/lib/ruby/gems/1.9.1/gems/wxruby-ruby19-2.0.1-x86_64-linux/lib/wx/classes/clientdc.rb:8: warning: method redefined; discarding old initialize
/opt/rubies/ruby-1.9.2-p0/lib/ruby/gems/1.9.1/gems/wxruby-ruby19-2.0.1-x86_64-linux/lib/wx/classes/paintdc.rb:7: warning: method redefined; discarding old initialize
/opt/rubies/ruby-1.9.2-p0/lib/ruby/gems/1.9.1/gems/wxruby-ruby19-2.0.1-x86_64-linux/lib/wx/classes/data_object.rb:3: warning: method redefined; discarding old get_preferred_format
/opt/rubies/ruby-1.9.2-p0/lib/ruby/gems/1.9.1/gems/wxruby-ruby19-2.0.1-x86_64-linux/lib/wx/classes/data_object.rb:7: warning: method redefined; discarding old get_format_count
/opt/rubies/ruby-1.9.2-p0/lib/ruby/gems/1.9.1/gems/wxruby-ruby19-2.0.1-x86_64-linux/lib/wx/classes/data_object.rb:11: warning: method redefined; discarding old get_data_size
/opt/rubies/ruby-1.9.2-p0/lib/ruby/gems/1.9.1/gems/wxruby-ruby19-2.0.1-x86_64-linux/lib/wx/classes/validator.rb:4: warning: method redefined; discarding old clone
/opt/rubies/ruby-1.9.2-p0/lib/ruby/gems/1.9.1/gems/wxruby-ruby19-2.0.1-x86_64-linux/lib/wx/classes/data_object_simple.rb:3: warning: method redefined; discarding old get_data_size
/opt/rubies/ruby-1.9.2-p0/lib/ruby/gems/1.9.1/gems/wxruby-ruby19-2.0.1-x86_64-linux/lib/wx/classes/app.rb:30: warning: method redefined; discarding old on_assert_failure

(wxruby:15467): Gtk-WARNING **: Error parsing gtk-icon-sizes string:
  'panel-menu=24,24
panel=20,20
gtk-button=18,18
gtk-large-toolbar=24,24'
/opt/rubies/ruby-1.9.2-p0/lib/ruby/gems/1.9.1/gems/wxruby-ruby19-2.0.1-x86_64-linux/lib/wx/classes/app.rb:16: [BUG] Segmentation fault
ruby 1.9.2p0 (2010-08-18 revision 29036) [x86_64-linux]

-- control frame ----------
c:0006 p:---- s:0017 b:0017 l:000016 d:000016 CFUNC  :on_run
c:0005 p:---- s:0015 b:0015 l:000014 d:000014 CFUNC  :main_loop
c:0004 p:0053 s:0012 b:0012 l:000011 d:000011 METHOD /opt/rubies/ruby-1.9.2-p0/lib/ruby/gems/1.9.1/gems/wxruby-ruby19-2.0.1-x86_64-linux/lib/wx/classes/app.rb:16
c:0003 p:0062 s:0006 b:0006 l:001148 d:001c38 EVAL   minimal.rb:73
c:0002 p:---- s:0004 b:0004 l:000003 d:000003 FINISH
c:0001 p:0000 s:0002 b:0002 l:001148 d:001148 TOP   
---------------------------
-- Ruby level backtrace information ----------------------------------------
minimal.rb:73:in `<main>'
/opt/rubies/ruby-1.9.2-p0/lib/ruby/gems/1.9.1/gems/wxruby-ruby19-2.0.1-x86_64-linux/lib/wx/classes/app.rb:16:in `run'
/opt/rubies/ruby-1.9.2-p0/lib/ruby/gems/1.9.1/gems/wxruby-ruby19-2.0.1-x86_64-linux/lib/wx/classes/app.rb:16:in `main_loop'
/opt/rubies/ruby-1.9.2-p0/lib/ruby/gems/1.9.1/gems/wxruby-ruby19-2.0.1-x86_64-linux/lib/wx/classes/app.rb:16:in `on_run'

-- C level backtrace information -------------------------------------------
/opt/rubies/ruby-1.9.2-p0/lib/libruby.so.1.9(rb_vm_bugreport+0x5f) [0x7fb98243c48f]
/opt/rubies/ruby-1.9.2-p0/lib/libruby.so.1.9(+0x5fff6) [0x7fb982324ff6]
/opt/rubies/ruby-1.9.2-p0/lib/libruby.so.1.9(rb_bug+0xb3) [0x7fb982325193]
/opt/rubies/ruby-1.9.2-p0/lib/libruby.so.1.9(+0x109285) [0x7fb9823ce285]
/lib/libpthread.so.0(+0xfb40) [0x7fb9820b7b40]
/usr/lib/libpixman-1.so.0(pixman_image_composite32+0x668) [0x7fb976b5f9e8]
/usr/lib/libcairo.so.2(+0x29463) [0x7fb9780b1463]
/usr/lib/libcairo.so.2(+0x2a61c) [0x7fb9780b261c]
/usr/lib/libcairo.so.2(+0x2c31d) [0x7fb9780b431d]
/usr/lib/libcairo.so.2(+0x2c55e) [0x7fb9780b455e]
/usr/lib/libcairo.so.2(+0x49f56) [0x7fb9780d1f56]
/usr/lib/libcairo.so.2(+0x2243e) [0x7fb9780aa43e]
/usr/lib/libcairo.so.2(cairo_fill_preserve+0x1d) [0x7fb9780a143d]
/usr/lib/librsvg-2.so.2(+0x29f8e) [0x7fb96f89df8e]
/usr/lib/librsvg-2.so.2(+0x248a0) [0x7fb96f8988a0]
/usr/lib/librsvg-2.so.2(+0x1d258) [0x7fb96f891258]
/usr/lib/librsvg-2.so.2(+0x1eb53) [0x7fb96f892b53]
/usr/lib/librsvg-2.so.2(+0x1f093) [0x7fb96f893093]
/usr/lib/librsvg-2.so.2(+0x1eb53) [0x7fb96f892b53]
/usr/lib/librsvg-2.so.2(+0x1ef64) [0x7fb96f892f64]
/usr/lib/librsvg-2.so.2(+0x1eb53) [0x7fb96f892b53]
/usr/lib/librsvg-2.so.2(rsvg_handle_render_cairo_sub+0xca) [0x7fb96f89eb1a]
/usr/lib/librsvg-2.so.2(rsvg_handle_get_pixbuf_sub+0x105) [0x7fb96f89f065]
/usr/lib/gdk-pixbuf-2.0/2.10.0/loaders/libpixbufloader-svg.so(+0xd6b) [0x7fb96faa9d6b]
/usr/lib/libgdk_pixbuf-2.0.so.0(gdk_pixbuf_loader_close+0xf9) [0x7fb97d655889]
/usr/lib/libgdk_pixbuf-2.0.so.0(+0x89a6) [0x7fb97d6539a6]
/usr/lib/libgdk_pixbuf-2.0.so.0(gdk_pixbuf_new_from_stream_at_scale+0x81) [0x7fb97d653b01]
/usr/lib/libgtk-x11-2.0.so.0(+0x104eec) [0x7fb97e36eeec]
/usr/lib/libgtk-x11-2.0.so.0(gtk_icon_info_load_icon+0x72) [0x7fb97e36f612]
/usr/lib/libgtk-x11-2.0.so.0(gtk_icon_theme_load_icon+0x13f) [0x7fb97e37185f]
/usr/lib/libgtk-x11-2.0.so.0(gtk_icon_set_render_icon+0x5ea) [0x7fb97e36bfaa]
/usr/lib/libgtk-x11-2.0.so.0(gtk_widget_render_icon+0xea) [0x7fb97e4c334a]
/usr/lib/libgtk-x11-2.0.so.0(+0x1185d4) [0x7fb97e3825d4]
/usr/lib/libgtk-x11-2.0.so.0(+0x1185f9) [0x7fb97e3825f9]
/usr/lib/libgobject-2.0.so.0(g_closure_invoke+0xa9) [0x7fb97cae29b9]
/usr/lib/libgobject-2.0.so.0(+0x23da1) [0x7fb97caf7da1]
/usr/lib/libgobject-2.0.so.0(g_signal_emit_valist+0x7e6) [0x7fb97caf9996]
/usr/lib/libgobject-2.0.so.0(g_signal_emit_by_name+0x208) [0x7fb97caf9ce8]
/usr/lib/libgtk-x11-2.0.so.0(+0x1a5138) [0x7fb97e40f138]
/usr/lib/libgtk-x11-2.0.so.0(+0x11ae2f) [0x7fb97e384e2f]
/usr/lib/libgobject-2.0.so.0(g_closure_invoke+0xa9) [0x7fb97cae29b9]
/usr/lib/libgobject-2.0.so.0(+0x23da1) [0x7fb97caf7da1]
/usr/lib/libgobject-2.0.so.0(g_signal_emit_valist+0x7e6) [0x7fb97caf9996]
/usr/lib/libgobject-2.0.so.0(g_signal_emit_by_name+0x208) [0x7fb97caf9ce8]
/usr/lib/libgtk-x11-2.0.so.0(+0x1a5138) [0x7fb97e40f138]
/usr/lib/libgtk-x11-2.0.so.0(+0x1422af) [0x7fb97e3ac2af]
/usr/lib/libgobject-2.0.so.0(g_closure_invoke+0x15e) [0x7fb97cae2a6e]
/usr/lib/libgobject-2.0.so.0(+0x23da1) [0x7fb97caf7da1]
/usr/lib/libgobject-2.0.so.0(g_signal_emit_valist+0x7e6) [0x7fb97caf9996]
/usr/lib/libgobject-2.0.so.0(g_signal_emit_by_name+0x208) [0x7fb97caf9ce8]
/usr/lib/libgtk-x11-2.0.so.0(+0x1a5138) [0x7fb97e40f138]
/usr/lib/libgtk-x11-2.0.so.0(+0x13c080) [0x7fb97e3a6080]
/usr/lib/libgtk-x11-2.0.so.0(gtk_menu_popup+0x1eb) [0x7fb97e3a7a7b]
/usr/lib/libgtk-x11-2.0.so.0(+0x1445a7) [0x7fb97e3ae5a7]
/usr/lib/libgtk-x11-2.0.so.0(+0x1446b9) [0x7fb97e3ae6b9]
/usr/lib/libgtk-x11-2.0.so.0(+0x146d1e) [0x7fb97e3b0d1e]
/usr/lib/libgobject-2.0.so.0(g_closure_invoke+0x15e) [0x7fb97cae2a6e]
/usr/lib/libgobject-2.0.so.0(+0x23da1) [0x7fb97caf7da1]
/usr/lib/libgobject-2.0.so.0(g_signal_emit_valist+0x7e6) [0x7fb97caf9996]
/usr/lib/libgobject-2.0.so.0(g_signal_emit+0x83) [0x7fb97caf9f53]
/usr/lib/libgtk-x11-2.0.so.0(gtk_menu_item_select+0x50) [0x7fb97e3af930]
/usr/lib/libgtk-x11-2.0.so.0(+0x14a382) [0x7fb97e3b4382]
/usr/lib/libgtk-x11-2.0.so.0(+0x14b2ca) [0x7fb97e3b52ca]
/usr/lib/libgtk-x11-2.0.so.0(+0x13a9d8) [0x7fb97e3a49d8]
/usr/lib/libgobject-2.0.so.0(g_closure_invoke+0x15e) [0x7fb97cae2a6e]
/usr/lib/libgobject-2.0.so.0(+0x24120) [0x7fb97caf8120]
/usr/lib/libgobject-2.0.so.0(g_signal_emit_valist+0x62b) [0x7fb97caf97db]
/usr/lib/libgobject-2.0.so.0(g_signal_emit+0x83) [0x7fb97caf9f53]
/usr/lib/libgtk-x11-2.0.so.0(+0x2536df) [0x7fb97e4bd6df]
/usr/lib/libgtk-x11-2.0.so.0(gtk_propagate_event+0xc3) [0x7fb97e39ce73]
/usr/lib/libgtk-x11-2.0.so.0(gtk_main_do_event+0x2eb) [0x7fb97e39df4b]
/usr/lib/libgdk-x11-2.0.so.0(+0x5c74c) [0x7fb97e01774c]
/lib/libglib-2.0.so.0(g_main_context_dispatch+0x1f2) [0x7fb97c429342]
/lib/libglib-2.0.so.0(+0x442a8) [0x7fb97c42d2a8]
/lib/libglib-2.0.so.0(g_main_loop_run+0x195) [0x7fb97c42d7b5]
/usr/lib/libgtk-x11-2.0.so.0(gtk_main+0xa7) [0x7fb97e39e3e7]
/opt/rubies/ruby-1.9.2-p0/lib/ruby/gems/1.9.1/gems/wxruby-ruby19-2.0.1-x86_64-linux/lib/wxruby2.so(_ZN11wxEventLoop3RunEv+0x48) [0x7fb97fbafeb8]
/opt/rubies/ruby-1.9.2-p0/lib/ruby/gems/1.9.1/gems/wxruby-ruby19-2.0.1-x86_64-linux/lib/wxruby2.so(_ZN9wxAppBase8MainLoopEv+0x4b) [0x7fb97f99f8db]
/opt/rubies/ruby-1.9.2-p0/lib/ruby/gems/1.9.1/gems/wxruby-ruby19-2.0.1-x86_64-linux/lib/wxruby2.so(+0x4b94b8) [0x7fb97f2b84b8]
/opt/rubies/ruby-1.9.2-p0/lib/libruby.so.1.9(+0x16de46) [0x7fb982432e46]
/opt/rubies/ruby-1.9.2-p0/lib/libruby.so.1.9(rb_funcall+0x115) [0x7fb982433785]
/opt/rubies/ruby-1.9.2-p0/lib/ruby/gems/1.9.1/gems/wxruby-ruby19-2.0.1-x86_64-linux/lib/wxruby2.so(_ZN16SwigDirector_App5OnRunEv+0x2d) [0x7fb97f2ba48d]
/opt/rubies/ruby-1.9.2-p0/lib/ruby/gems/1.9.1/gems/wxruby-ruby19-2.0.1-x86_64-linux/lib/wxruby2.so(_Z7wxEntryRiPPw+0x85) [0x7fb97f8c85f5]
/opt/rubies/ruby-1.9.2-p0/lib/ruby/gems/1.9.1/gems/wxruby-ruby19-2.0.1-x86_64-linux/lib/wxruby2.so(+0x4b93a0) [0x7fb97f2b83a0]
/opt/rubies/ruby-1.9.2-p0/lib/libruby.so.1.9(+0x172948) [0x7fb982437948]
/opt/rubies/ruby-1.9.2-p0/lib/libruby.so.1.9(+0x165329) [0x7fb98242a329]
/opt/rubies/ruby-1.9.2-p0/lib/libruby.so.1.9(+0x16c4aa) [0x7fb9824314aa]
/opt/rubies/ruby-1.9.2-p0/lib/libruby.so.1.9(rb_iseq_eval_main+0x280) [0x7fb9824318d0]
/opt/rubies/ruby-1.9.2-p0/lib/libruby.so.1.9(+0x647b2) [0x7fb9823297b2]
/opt/rubies/ruby-1.9.2-p0/lib/libruby.so.1.9(ruby_exec_node+0x1d) [0x7fb9823297dd]
/opt/rubies/ruby-1.9.2-p0/lib/libruby.so.1.9(ruby_run_node+0x1e) [0x7fb98232b25e]
ruby(main+0x4b) [0x40094b]
/lib/libc.so.6(__libc_start_main+0xfe) [0x7fb98147bd8e]
ruby() [0x400839]

[NOTE]
You may have encountered a bug in the Ruby interpreter or extension libraries.
Bug reports are welcome.
For details: http://www.ruby-lang.org/bugreport.html

Aborted
>> quintus@kerberos => /opt/rubies/ruby-1.9.2-p0/lib/ruby/gems/1.9.1/gems/wxruby-ruby19-2.0.1-x86_64-linux/samples/minimal
$